Использование Perl API клиента Mikrotik

Одно время для управления правилами Mikrotik использовал ssh (http://wiki.mikrotik.com/wiki/Use_SSH_to_execute_commands_(DSA_key_login)), однако заметил резкий рост потребляемой памяти : Слева потребление памяти с использованием SSH, справа с использованием API. Реальное потребление на порядок ниже, но после изменений я так и не перезагружал маршрутизатор, а самостоятельно он память освобождать не хочет, как видно из графиков он её освобождает, но только при достижении критического значения.

Блокирование спама и уведомление пользователей (Mikrotik, UTM 4)

Решил немного облегчить себе жизнь. Для определения злоумышленников либо инфицированных хостов используем правила:
/ip firewall filter
add action=add-src-to-address-list address-list=spammer address-list-timeout=4h chain=forward comment=\                                     
"Detect and add-list SMTP virus or spammers" connection-limit=30,32 disabled=no dst-port=25 limit=50,5\
protocol=tcp src-address=!IP-адрес_моего_почтового_сервера 
add action=drop chain=forward comment="BLOCK SPAMMERS OR INFECTED USERS" disabled=no dst-port=25\
protocol=tcp src-address-list=spammer

Bacula - резервное копирование (Debian, FreeBSD)

Данная статья не претендует на руководство, и рассматривается исключительно как шпаргалка. Что же такое Bacula? Для этого обратимся к первоисточнику - www.bacula.org. - Bacula - это программный комплекс позволяющий системному администратору управлять резервным копированием и восстановлением данных используя различные типы носителей, включая ленты и диски. С технической точки зрения, это сетевой клиент/сервер резервного копирования. Бакула состоит из следующих компонентов:

Mikrotik RB-750 изолирование портов и фильтрация сетей

Сперва создаем и настраиваем мост: Создаем мост: /interface bridge add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled auto-mac=yes comment="" disabled=no forward-delay=15s l2mtu=1524 \ max-message-age=20s mtu=1500 name=bridge1 priority=0x8000 protocol-mode=rstp transmit-hold-count=6 Параметры моста: /interface bridge settings set use-ip-firewall=yes use-ip-firewall-for-pppoe=no use-ip-firewall-for-vlan=no Добавляем порты: /interface bridge port

Астериск и несколько входящих портов (Multiple listening ports for Asterisk)

Столкнулся с тем, что некоторые "провайдеры", а также гостиницы и кафе фильтруют у себя порт 5060. Asterisk не позволяет "слушать" несколько портов, а для единичных случаев, несколько неудобно менять основной порт. Решение максимально простое -
iptables -A PREROUTING -t nat -i eth0 -p udp --dport 9060 -j REDIRECT --to-port 5060
Естественно, в случае необходимости, можно не останавливаться на двух портах.

Debian "Lenny", Asterisk, Zaptel, Digium TDM800P и "Ослик" OSLEC

Появилась необходимость давить эхо на картах, после использования fxotune и правки параметров rxgain и txgain ситуация несколько улучшилась, но легкий дискомфорт остался. В документации к zaptel (README.Debian.gz) указано, что используемый по умолчанию модуль эхокомпенсации - Open Source Line Echo Canceller (OSLEC), однако
#lsmod |grep oslec
отображал безмятежную пустоту командной строки, и даже после загрузки модуля -
#insmod /lib/modules/2.6.26-2-686/misc/oslec/oslec.ko
#lsmod |grep oslec

Debian "Sid" и ext4

Решился на переход на ext4, после недолгого поиска нашел решение. Т.к. в репозиториях, в том числе и experimental, на данный момент нет ядра 2.6.28, добавил в /etc/apt/source.list -
deb http://kernel-archive.buildserver.net/debian-kernel trunk main
aptitude install linux-image-2.6.28-1-686
при установке ядра возникла проблема - постустановочный скрипт не смог найти update-grub в директории /sbin, что

Уведомления Cacti через Jabber

В связи с тем, что МТС запретила отправку смс через почту, пришлось думать об обходных путях уведомлений. Остановился на jabber.
Попытаюсь вкратце изложить.
Поиск в google.com дал ссылку на следующий ресурс - http://jabberd.jabberstudio.org/2/docs/sysadmin_jobmon.html , я использовал скрипт http://jabberd.jabberstudio.org/2/docs/tools/jabber_alert.pl .Осталось только его прикрутить с Cacti (http://www.cacti.net/) .
В качестве почтового сервера используется postfix, добавляем в aliases строку вида -

Трансляция интернет-радио и локальной музыкальной коллекции с помощью icecast2 и mpd в Debian 4.0 Etch

В первую очередь разберемся что же из себя представляют вышеназванные программы
- icecast2 (http://www.icecast.org/) - потоковый медиа-сервер, поддерживающий Ogg Vorbis и MP3 аудио потоки. Icecast - проект с открытым исходным текстом и распространяющийся на условиях лицензии GPLv2

- mpd (http://www.MusicPD.org) - предоставляет удаленный доступ для воспроизведения музыки (MP3, Ogg Vorbis, FLAC, AAC, Mod, и wave форматов) управлением плей-листа и пр. MPD также является проектом с открытым исходным текстом и распространяющимся на условиях лицензии GPLv2

kernel 2.6.24 (Debian Sid) и Dell inspiron 3800

Обновил ядро на 2.6.24 до этого работал на 2.6.22.
Первая неприятность - не заработала звуковая карта (ESS Technology ES1983S Maestro-3i)
Поиск в Google помог - google.com, как оказалось, начиная с версии ядра 2.6.23 были удалены драйвера :
linux-2.6 (2.6.23-1) unstable; urgency=low
...
* Remove binary only firmwares for:
...
- ESS Allegro/Maestro3
Проблема решилась просто - установкой оных с сайта alsa - ftp://ftp.alsa-project.org/pub/firmware/

Подписаться на