Что такое EoIP тунель? По сути это L2-тунель поверх IP. Говоря доступным языком мы можем создать "прозрачную" сеть между удаленными маршрутизаторами. Для реализации тунеля нам необходимы два адреса - по одному с каждой стороны. В случае использования интернет потребуется два внешних (реальных IP). В данной заметке я опишу ситуацию когда имеется только один внешний IP, а второй маршрутизатор находится за NAT'ом. Изображение удалено. Итак мы имеем два mikrotik-маршрутизатора MT1 и MT2. MT1 - маршрутизатор с внешним IP (1.1.1.1), МТ2 - маршрутизатор находящийся за NAT'ом с внутренним IP 192.168.0./24. Для начала построим PPtPтунель. МТ1 будет выступать в качестве сервера

/interface pptp-server server set authentication=mschap1,mschap2 default-profile=default-encryption enabled=yes keepalive-timeout=30 \ max-mru=1460 max-mtu=1460 mrru=disabled /interface pptp-server add disabled=no name=pptp-in user=pptp /ppp secret add caller-id="" disabled=no limit-bytes-in=0 limit-bytes-out=0 local-address=10.10.10.1 name=pptp \ password=password profile=default-encryption remote-address=10.10.10.2 service=pptp

МТ2 клиент

/interface pptp-client add add-default-route=no allow=mschap1,mschap2 connect-to=1.1.1.1 dial-on-demand=no disabled=no \ max-mru=1460 max-mtu=1460 mrru=disabled name=pptp-out1 password=password \ profile=default-encryption user=pptp

В итоге получим тунель с адресами 10.10.10.1 и 10.10.10.2. Теперь можем настроить EoIP-тунель между двумя этими IP MT1

/interface eoip add arp=enabled disabled=no l2mtu=65535 local-address=10.10.10.1 mtu=1500 name=eoip-tunnel1 \ remote-address=10.10.10.2 tunnel-id=0

MT2

/interface eoip add arp=enabled disabled=no l2mtu=65535 local-address=10.10.10.2 mtu=1500 name=eoip-tunnel1\ remote-address=10.10.10.1 tunnel-id=0

В результате мы получим на обоих маршрутизаторах интерфейсы eoip-tunnel, с которыми уже сможем работать.